Partial Outage

Incident Report for First Delivery

Resolved

Between 21:59 UTC - 22:06, we experienced a brief period of partial outage and elevated request latency lasting approximately 5–7 minutes.

The underlying issue has been identified and mitigated, and services have since recovered. We are actively monitoring to ensure continued stability.

Thank you for your patience and understanding.
Posted Oct 17, 2025 - 22:12 UTC

Update

Issue resolved
Posted Oct 17, 2025 - 22:07 UTC

Investigating

We are currently investigating an issue
Posted Oct 17, 2025 - 22:00 UTC
This incident affected: API, Dispatch Portal, and Merchant App.